Test taks failing with building cbiz.

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Test taks failing with building cbiz.

Anchit Jindal
Dear Ofbiz team,

From yesterday I am getting errors related to xsd while I am trying to build Ofbiz looks like testTask is failing and when I tried skipping it I got another error. Below are some error logs.

2021-07-19 18:17:58,182 |kJoinPool-1-worker-3 ||UtilXml                                 |W| [UtilXml.LocalResolver.resolveEntity] could not find LOCAL DTD/Schema with publicId [null] and the file/resource is [service-eca.xsd]
2021-07-19 18:17:58,186 |JoinPool-1-worker-11 ||ServiceEcaUtil                          |E| null
org.apache.ofbiz.base.config.GenericConfigException: Error reading ComponentResourceHandler from XML file [party] with loaderName [main] and location [servicedef/secas.xml] (Premature end of file.)
        at org.apache.ofbiz.base.component.ComponentResourceHandler.getDocument(ComponentResourceHandler.java:74) ~[ofbiz.jar:?]
        at org.apache.ofbiz.service.eca.ServiceEcaUtil.getEcaDefinitions(ServiceEcaUtil.java:106) [ofbiz.jar:?]
        at org.apache.ofbiz.service.eca.ServiceEcaUtil.lambda$createEcaLoaderCallable$0(ServiceEcaUtil.java:94) [ofbiz.jar:?]
        at java.util.concurrent.ForkJoinTask$AdaptedCallable.exec(ForkJoinTask.java:1448) [?:?]
        at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:290) [?:?]
        at java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1020) [?:?]
        at java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1656) [?:?]
        at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1594) [?:?]
        at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:183) [?:?]
Caused by: org.xml.sax.SAXParseException: Premature end of file.
        at org.apache.xerces.parsers.DOMParser.parse(Unknown Source) ~[xercesImpl-2.9.1.jar:?]
        at org.apache.ofbiz.base.util.UtilXml.readXmlDocument(UtilXml.java:581) ~[ofbiz.jar:?]
        at org.apache.ofbiz.base.util.UtilXml.readXmlDocument(UtilXml.java:420) ~[ofbiz.jar:?]
        at org.apache.ofbiz.base.component.ComponentResourceHandler.getDocument(ComponentResourceHandler.java:72) ~[ofbiz.jar:?]

I have found that the xsd defined in xml files is causing the issue. When i tried to validate xml online. it gives me the same error but when i manually give xsd to xml then it works fine.

Does anyone else face the same issue or is there any new update that I need to merge? Can someone please help to resolve this issue?

Thanks, Anchit