[
https://issues.apache.org/jira/browse/OFBIZ-11963?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17181109#comment-17181109 ]
Jacques Le Roux commented on OFBIZ-11963:
-----------------------------------------
bq. Also, I don't like empty lines in Javadocs, so usually I find/replace it.
This goes against what is currently doing
For instance with initially
{code:java}
/** Returns a boolean, result of whenStr evaluation with context.
* If whenStr is empty return defaultReturn.
* @param context A <code>Map</code> containing initial variables
* @param whenStr A <code>String</code> condition expression
* @param defaultReturn A <code>boolean</code> default return value
* @return A <code>boolan</code> result of evaluation
*/
{code}
It transforms to:
{code:java}
/**
* Returns a boolean, result of whenStr evaluation with context. If whenStr is empty return defaultReturn.
*
* @param context
* A <code>Map</code> containing initial variables
* @param whenStr
* A <code>String</code> condition expression
* @param defaultReturn
* A <code>boolean</code> default return value
* @return A <code>boolan</code> result of evaluation
*/
{code}
I like the 1st because it's tight. THe 2nd (inherited from Sun conventions) is maybe easier to read.
It seems a moot point to me. I'll ask the community about this trival point before we get automated conflicts :)
> Checkstyle: Variable must be private and have accessor methods
> --------------------------------------------------------------
>
> Key: OFBIZ-11963
> URL:
https://issues.apache.org/jira/browse/OFBIZ-11963> Project: OFBiz
> Issue Type: Sub-task
> Components: ALL COMPONENTS
> Affects Versions: Trunk
> Reporter: Suraj Khurana
> Assignee: Suraj Khurana
> Priority: Major
> Attachments: OFBIZ-11963-plugins.patch, OFBIZ-11963.patch
>
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)