[
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15372702#comment-15372702 ]
Jacques Le Roux commented on OFBIZ-7763:
----------------------------------------
I read in the commit comment
bq. Today only alphabetic variable with '_' are detected (i.e. my_variable==null).
and in commit this snippet
{code}
+ if (UtilValidate.isNotEmpty(expression)) {
+ //analyse expression to find variables by split non alpha, ignoring "_" to allow my_variable usage
+ String [] variables = expression.split("[\\P{Alpha}&&[^_]]+");
+ for (String variable: variables)
+ if(!vars.containsKey(variable)) vars.put(variable, null);
+ }
{code}
Should we not make this clearer somewhere (not sure how, just asking at this point)?
> Replace bshInterpreter with groovyShell
> ---------------------------------------
>
> Key: OFBIZ-7763
> URL:
https://issues.apache.org/jira/browse/OFBIZ-7763> Project: OFBiz
> Issue Type: Improvement
> Components: framework
> Affects Versions: Trunk
> Reporter: Gil Portenseigne
> Assignee: Gil Portenseigne
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the project, and improve readability and fonctionnalities following [~deepak.dixit] idea expressed here
https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972--
This message was sent by Atlassian JIRA
(v6.3.4#6332)