OnePageCheckout should reuse UpdateCart while first time rendering
------------------------------------------------------------------ Key: OFBIZ-4436 URL: https://issues.apache.org/jira/browse/OFBIZ-4436 Project: OFBiz Issue Type: Improvement Components: specialpurpose/ecommerce Affects Versions: Release Branch 11.04 Reporter: Kiran Gawde Priority: Minor When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Kiran Gawde updated OFBIZ-4436: ------------------------------- Attachment: OFBIZ-4436-UpdateCartReuse.patch Patch shows how CartScreens.xml#UpdateCart can be reused. > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Priority: Minor > Attachments: OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Kiran Gawde updated OFBIZ-4436: ------------------------------- Attachment: OFBIZ-4436-OrderScreensXml.patch OrderScreen.xml#OnePageCheckout updated. removed ShowCart.groovy > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Priority: Minor > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Sascha Rodekamp reassigned OFBIZ-4436: -------------------------------------- Assignee: Sascha Rodekamp > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13109516#comment-13109516 ] Sascha Rodekamp commented on OFBIZ-4436: ---------------------------------------- Hi Kiran, that's really true we have a code duplication here. The question is if we should include the UpdateCart in the OnePageCheckOut Ftl, i can imagine, that this can confuse developers. I.e. when someone changes the updateCart FTL and he don't notice that we have a relation to the OnePageCheckOut. That could possible break the OPCO, got my point? I would prefer to create a generic FTL called ShoppingCartCheckOutFirstStep.ftl (i think we could find a shorter/better name), place the Step 1 code in the new file and include this one in the UpdateCart and the OPCO. Any opinions? > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13109634#comment-13109634 ] Kiran Gawde commented on OFBIZ-4436: ------------------------------------ Hello Sascha, I agree with you about choosing better name. How about OnePageCheckoutCart. I don't want to mention first step because, in my case, I have all the forms visible at once. If we go with above name, it can replace, UpdateCart. If you strongly feel about leaving the UpdateCart.ftl there, you can include above in there. Regards, Kiran Gawde Senior Software Architect Object Edge Inc (925) 943 5558 x108 "There are two kind of people: Those who do the work and those who take the credit. Try to be in the first group because there is less competition there." "Never give up on what you really want to do. The person with big dreams is more powerful than one with all the facts". From: "Sascha Rodekamp (JIRA)" <[hidden email]> To: [hidden email] Date: 09/21/2011 07:03 AM Subject: [jira] [Commented] (OFBIZ-4436) OnePageCheckout should reuse UpdateCart while first time rendering [ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13109516#comment-13109516 ] Sascha Rodekamp commented on OFBIZ-4436: ---------------------------------------- Hi Kiran, that's really true we have a code duplication here. The question is if we should include the UpdateCart in the OnePageCheckOut Ftl, i can imagine, that this can confuse developers. I.e. when someone changes the updateCart FTL and he don't notice that we have a relation to the OnePageCheckOut. That could possible break the OPCO, got my point? I would prefer to create a generic FTL called ShoppingCartCheckOutFirstStep.ftl (i think we could find a shorter/better name), place the Step 1 code in the new file and include this one in the UpdateCart and the OPCO. Any opinions? OFBIZ-4436-UpdateCartReuse.patch by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13112354#comment-13112354 ] Sascha Rodekamp commented on OFBIZ-4436: ---------------------------------------- Hi Kiran, i rethink my previous comment. And i think i was wrong. We don't need a separate ftl, because UpdateCart is the original Screen which is used to update a shopping cart so it is absolutely sufficient to reuse this screen in (for example) the OnePageCheckOutProcess.ftl, there shouldn't be any confusions about it. > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Sascha Rodekamp closed OFBIZ-4436. ---------------------------------- Resolution: Fixed Fix Version/s: SVN trunk Release Branch 11.04 Thanks Kiran your patch is in Trunk @Rev1173975 11.04 @Rev1173978 > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Fix For: Release Branch 11.04, SVN trunk > > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
In reply to this post by Nicolas Malin (Jira)
[ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13109634#comment-13109634 ] Kiran Gawde edited comment on OFBIZ-4436 at 9/26/11 4:41 PM: ------------------------------------------------------------- Hello Sascha, I agree with you about choosing better name. How about OnePageCheckoutCart. I don't want to mention first step because, in my case, I have all the forms visible at once. If we go with above name, it can replace, UpdateCart. If you strongly feel about leaving the UpdateCart.ftl there, you can include above in there. Regards, Kiran Gawde was (Author: kiran_gawde): Hello Sascha, I agree with you about choosing better name. How about OnePageCheckoutCart. I don't want to mention first step because, in my case, I have all the forms visible at once. If we go with above name, it can replace, UpdateCart. If you strongly feel about leaving the UpdateCart.ftl there, you can include above in there. Regards, Kiran Gawde Senior Software Architect Object Edge Inc (925) 943 5558 x108 "There are two kind of people: Those who do the work and those who take the credit. Try to be in the first group because there is less competition there." "Never give up on what you really want to do. The person with big dreams is more powerful than one with all the facts". From: "Sascha Rodekamp (JIRA)" <[hidden email]> To: [hidden email] Date: 09/21/2011 07:03 AM Subject: [jira] [Commented] (OFBIZ-4436) OnePageCheckout should reuse UpdateCart while first time rendering [ https://issues.apache.org/jira/browse/OFBIZ-4436?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13109516#comment-13109516 ] Sascha Rodekamp commented on OFBIZ-4436: ---------------------------------------- Hi Kiran, that's really true we have a code duplication here. The question is if we should include the UpdateCart in the OnePageCheckOut Ftl, i can imagine, that this can confuse developers. I.e. when someone changes the updateCart FTL and he don't notice that we have a relation to the OnePageCheckOut. That could possible break the OPCO, got my point? I would prefer to create a generic FTL called ShoppingCartCheckOutFirstStep.ftl (i think we could find a shorter/better name), place the Step 1 code in the new file and include this one in the UpdateCart and the OPCO. Any opinions? OFBIZ-4436-UpdateCartReuse.patch by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira > OnePageCheckout should reuse UpdateCart while first time rendering > ------------------------------------------------------------------ > > Key: OFBIZ-4436 > URL: https://issues.apache.org/jira/browse/OFBIZ-4436 > Project: OFBiz > Issue Type: Improvement > Components: specialpurpose/ecommerce > Affects Versions: Release Branch 11.04 > Reporter: Kiran Gawde > Assignee: Sascha Rodekamp > Priority: Minor > Fix For: Release Branch 11.04, SVN trunk > > Attachments: OFBIZ-4436-OrderScreensXml.patch, OFBIZ-4436-UpdateCartReuse.patch > > > When shipping options or coupon are changed the entire cart is updated by invoking UpdateCart. It returns output of UpdateCart screen. The same screen should be reused during original rendering to avoid code duplication. -- This message is automatically generated by JIRA. For more information on JIRA, see: http://www.atlassian.com/software/jira |
Free forum by Nabble | Edit this page |