[jira] [Created] (OFBIZ-7520) Minilang code readability and consistency improvements

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (OFBIZ-7520) Minilang code readability and consistency improvements

Nicolas Malin (Jira)
Divesh Dutta created OFBIZ-7520:
-----------------------------------

             Summary: Minilang code readability and consistency improvements
                 Key: OFBIZ-7520
                 URL: https://issues.apache.org/jira/browse/OFBIZ-7520
             Project: OFBiz
          Issue Type: Improvement
          Components: ALL COMPONENTS
    Affects Versions: Upcoming Branch
            Reporter: Divesh Dutta
            Assignee: Divesh Dutta


Code written in minilang is not consistent through out the application and some times its hard to read. For eg:

{code}
<set from-field="productFacility.minimumStock"  field="minimumStock"/>
{code}

should be written as :


{code}
<set  field="minimumStock" from-field="productFacility.minimumStock" />
{code}

There are many such examples where code for all such tags in minilang can be improved, which will improve code readability and we will have consistency through out the application. This is a parent/place holder ticket, I will create logical sub-tickets for managing the effort.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)