[jira] [Updated] (OFBIZ-8471) Remove uneccessary call of isNotEmpty() to validate not null generic value

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (OFBIZ-8471) Remove uneccessary call of isNotEmpty() to validate not null generic value

Nicolas Malin (Jira)

     [ https://issues.apache.org/jira/browse/OFBIZ-8471?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ratnesh Upadhyay updated OFBIZ-8471:
------------------------------------
    Attachment: OFBIZ-8471.patch

Attached patch to review and push the mentioned improvement.

> Remove uneccessary call of isNotEmpty() to validate not null generic value
> --------------------------------------------------------------------------
>
>                 Key: OFBIZ-8471
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-8471
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: ALL COMPONENTS
>    Affects Versions: Upcoming Branch
>            Reporter: Ratnesh Upadhyay
>         Attachments: OFBIZ-8471.patch
>
>
> There are lots of places in code where we have used UtilValidate.isNotEmpty() to validate GenericValue object. GenericValue will always be null or not null, they will never empty. So instead of using utility method to validate them we should be using native checks onwards.
> Example:
> Currently we are validating generic value in following ways
> {code}
> if (UtilValidate.isNotEmpty(acctgTransEntry)) {
> {code}
> instead we will using it in this way:
> {code}
> if (acctgTransEntry != null ) {
> {code}
> Basically these validation methods should preferably be used on Strings or Lists and normal Maps.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)