Author: jacopoc
Date: Sat Jun 2 01:30:34 2007
New Revision: 543717
URL:
http://svn.apache.org/viewvc?view=rev&rev=543717Log:
Added comment about code that in my opinion is not correct. Any opinions?
Modified:
ofbiz/trunk/applications/accounting/src/org/ofbiz/accounting/payment/PaymentGatewayServices.java
Modified: ofbiz/trunk/applications/accounting/src/org/ofbiz/accounting/payment/PaymentGatewayServices.java
URL:
http://svn.apache.org/viewvc/ofbiz/trunk/applications/accounting/src/org/ofbiz/accounting/payment/PaymentGatewayServices.java?view=diff&rev=543717&r1=543716&r2=543717==============================================================================
--- ofbiz/trunk/applications/accounting/src/org/ofbiz/accounting/payment/PaymentGatewayServices.java (original)
+++ ofbiz/trunk/applications/accounting/src/org/ofbiz/accounting/payment/PaymentGatewayServices.java Sat Jun 2 01:30:34 2007
@@ -1085,6 +1085,9 @@
}
// return complete if no payment prefs were found
+ // JAC20070602: Is this correct? Shouldn't we check if the
+ // amountToCapture is > 0 as we are doing
+ // at the bottom of this method?
if (paymentPrefs == null || paymentPrefs.size() == 0) {
Debug.logWarning("No orderPaymentPreferences available to capture", module);
Map result = ServiceUtil.returnSuccess();