Hi,
I'd like to refactor the names of the test services for the credit card processor, because in my opinion, the existing names are confusing. However I have some doubts/questions. For example the auth services are: *Auth services* testCCProcessor testCCProcessorWithCapture testRandomAuthorize alwaysApproveCCProcessor alwaysApproveWithCaptureCCProcessor alwaysDeclineCCProcessor alwaysNsfCCProcessor alwaysBadExpireCCProcessor badExpireEvenCCProcessor I'd suggest to use the following naming convention: testCCProcessorAuth* (so that we can distinguish them from the testCCProcessorCapture* ones) For example: testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor) testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor) testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor) testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor) etc... What do you think? My question is: what is the intended use of alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I really don't understand for what they are used for? Thanks, Jacopo |
I would suggest following the National Retail Federation payment standards
http://nrf-arts.org If OFBIZ will continue to use JavaPOS http://www.JavaPOS.com in the E Commerence and POS portions of it's code. or if OFBIZ hopes to leveregae exisitng Point of Sale Equipment like Card Readers. Use POSTest to check your Credit Card code http://postest.sourceforge.net/ Alan DeRossett InstaPayment Inc. http://www.InstaPayment.com ----- Original Message ----- From: "Jacopo Cappellato" <[hidden email]> To: <[hidden email]> Sent: Sunday, July 01, 2007 9:52 AM Subject: Refactoring existing test cc payment gateway processor services > Hi, > > I'd like to refactor the names of the test services for the credit card > processor, because in my opinion, the existing names are confusing. > However I have some doubts/questions. > > For example the auth services are: > > *Auth services* > > testCCProcessor > testCCProcessorWithCapture > testRandomAuthorize > alwaysApproveCCProcessor > alwaysApproveWithCaptureCCProcessor > alwaysDeclineCCProcessor > alwaysNsfCCProcessor > alwaysBadExpireCCProcessor > badExpireEvenCCProcessor > > I'd suggest to use the following naming convention: > > testCCProcessorAuth* > (so that we can distinguish them from the testCCProcessorCapture* ones) > > For example: > testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor) > testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor) > testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor) > testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor) > etc... > > What do you think? > My question is: what is the intended use of > alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I > really don't understand for what they are used for? > > Thanks, > > Jacopo > |
In reply to this post by Jacopo Cappellato
My suggestion would be to plan a specific model for each method of
payment however to create a layer of abstraction for the OfBiz 2007/7/1, Jacopo Cappellato <[hidden email]>: > Hi, > > I'd like to refactor the names of the test services for the credit card > processor, because in my opinion, the existing names are confusing. > However I have some doubts/questions. > > For example the auth services are: > > *Auth services* > > testCCProcessor > testCCProcessorWithCapture > testRandomAuthorize > alwaysApproveCCProcessor > alwaysApproveWithCaptureCCProcessor > alwaysDeclineCCProcessor > alwaysNsfCCProcessor > alwaysBadExpireCCProcessor > badExpireEvenCCProcessor > > I'd suggest to use the following naming convention: > > testCCProcessorAuth* > (so that we can distinguish them from the testCCProcessorCapture* ones) > > For example: > testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor) > testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor) > testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor) > testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor) > etc... > > What do you think? > My question is: what is the intended use of > alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I > really don't understand for what they are used for? > > Thanks, > > Jacopo > > |
In reply to this post by Jacopo Cappellato
And what about moving all the test service definitions and
implementation into a separate service def file (serices_testpaymentgateway.xml) and class(TestPaymentGatewayServices.java)? Jacopo Jacopo Cappellato wrote: > Hi, > > I'd like to refactor the names of the test services for the credit card > processor, because in my opinion, the existing names are confusing. > However I have some doubts/questions. > > For example the auth services are: > > *Auth services* > > testCCProcessor > testCCProcessorWithCapture > testRandomAuthorize > alwaysApproveCCProcessor > alwaysApproveWithCaptureCCProcessor > alwaysDeclineCCProcessor > alwaysNsfCCProcessor > alwaysBadExpireCCProcessor > badExpireEvenCCProcessor > > I'd suggest to use the following naming convention: > > testCCProcessorAuth* > (so that we can distinguish them from the testCCProcessorCapture* ones) > > For example: > testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor) > testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor) > testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor) > testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor) > etc... > > What do you think? > My question is: what is the intended use of > alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I > really don't understand for what they are used for? > > Thanks, > > Jacopo |
Administrator
|
+1
Jacques De : "Jacopo Cappellato" <[hidden email]> > And what about moving all the test service definitions and > implementation into a separate service def file > (serices_testpaymentgateway.xml) and class(TestPaymentGatewayServices.java)? > > Jacopo > > > Jacopo Cappellato wrote: > > Hi, > > > > I'd like to refactor the names of the test services for the credit card > > processor, because in my opinion, the existing names are confusing. > > However I have some doubts/questions. > > > > For example the auth services are: > > > > *Auth services* > > > > testCCProcessor > > testCCProcessorWithCapture > > testRandomAuthorize > > alwaysApproveCCProcessor > > alwaysApproveWithCaptureCCProcessor > > alwaysDeclineCCProcessor > > alwaysNsfCCProcessor > > alwaysBadExpireCCProcessor > > badExpireEvenCCProcessor > > > > I'd suggest to use the following naming convention: > > > > testCCProcessorAuth* > > (so that we can distinguish them from the testCCProcessorCapture* ones) > > > > For example: > > testCCProcessorAuthAlwaysApprove (was alwaysApproveCCProcessor) > > testCCProcessorAuthAlwaysDecline (was alwaysDeclineCCProcessor) > > testCCProcessorAuthAlwaysNsfDecline (was alwaysNsfCCProcessor) > > testCCProcessorAuthAlwaysBadExpireDecline (was alwaysBadExpireCCProcessor) > > etc... > > > > What do you think? > > My question is: what is the intended use of > > alwaysApproveWithCaptureCCProcessor (and testCCProcessorWithCapture)? I > > really don't understand for what they are used for? > > > > Thanks, > > > > Jacopo |
Free forum by Nabble | Edit this page |